Wskazówki Dotyczące Rozwiązywania Błędu Aktualizacji RPM
Wskazówki Dotyczące Rozwiązywania Błędu Aktualizacji RPM

Wskazówki Dotyczące Rozwiązywania Błędu Aktualizacji RPM

Jeśli możesz mieć błąd aktualizacji RPM w swoim systemie, ta przyczyna pomoże Ci go naprawić.

Przyspiesz swój komputer w kilka minut

  • Krok 1: Pobierz i zainstaluj Restoro
  • Krok 2: Otwórz program i kliknij „Skanuj”
  • Krok 3: Kliknij „Napraw”, aby rozpocząć proces naprawy
  • Kliknij tutaj, aby uzyskać oprogramowanie, które poprawi wydajność komputera.

    opis Tom Cosimano 11/16/2002 09:11:50 UTC

    Z Pomocnika Bugzilli:Klient użytkownika: Mozilla/5.0U; (x11; Linux en-us; i686; rv:1.0.1) Gecko/20021003Opis problemu:Kiedy często uruchamiam program up2date, pojawia się błądUwaga: Myślę, że ten fakt zaczął się po tym, jak miałem wspólny problem opisany poniżej:http://www.rpm.org/hintskinks/repairdb/i wydawało mi się, że mam instrukcje, aby rozwiązać tego rodzaju problem, ale teraz mam ten błądWiadomość, gdy zrobię dobry up2date:Śledzenie (ostatnie połączenie): Plik "/usr/sbin/up2date", asortyment 20, w ?    Up2date_client ze skanowania rpcServer  "/usr/share/rhn/up2date_client/rpcServer plik.py", 10, wiersz ? wewnątrz Up2dateAuth ważny plik "/usr/share/rhn/up2date_client/up2dateAuth.py" а 6, № ?    trafność rpmSource  Plik "/usr/share/rhn/up2date_client/rpmSource.py", wiersz 11, ? za pomocą Import up2dateUtils "/usr/share/rhn/up2date_client/up2dateUtils file.py", linia telefoniczna 15, czy to jest?    Wartość rpmUtils "/usr/share/rhn/up2date_client/rpmUtils plik.py", 261, kolekcja z ?   rpm_version idzie do getRpmVersion() Plik "/usr/share/rhn/up2date_client/rpmUtils.257 py" zidentyfikowany w getRpmVersion.   Maksymalizuj błędy up2date. Zdefiniuj rpmerror("failed, jaką masz wersję buntów na minutęto działa. nJeśli pojawi się błąd, spróbuj uruchomić ten poradnik nnttrpm --rebuilddbnn")up2date_client.up2dateErrors.RpmError: błąd RPM. Wiadomość brzmiała:Nie jest możliwe określenie liczby wydań RPM, z których prawdopodobnie będziesz korzystać.Jeśli pojawi się ten błąd, spróbuj go pobiegać                --rebuilddb rpmPróbowałem uruchomić --rebuilddb rpm, który niewiele lub bez wątpienia wrócił natychmiast zBrak wiadomości.Liczba wersji wybranej wersji (przypadek powtarzalny:Jest zawszeObowiązujące kroki):jak grać:1. po prostu musisz uruchomić up2date2.3.Rzeczywiste wyniki: Traceback (ostatnie połączenie):  "/usr/sbin/up2date", plik komputerowy 20, wiersz ?    spowodowane przez import up2date_client rpcServer  "/usr/share/rhn/up2date_client/rpcServer plik.py", 10, wiersz ?   Importuj up2dateAuth Plik "/usr/share/rhn/up2date_client/up2dateAuth.py", wpisuje niedrogie wakacje, ?    Importuj obroty na minutę źródło  Plik "/usr/share/rhn/up2date_client/rpmSource.py", wiersz dwunasty, podczas gdy w ?   Importuj up2dateUtils  "/usr/share/rhn/up2date_client/up2dateUtils plik.py", kabel 15? Jeśli importujesz rpmUtils "/usr/share/rhn/up2date_client/rpmUtils plik.py", przewód 261, jest w ?   rpm_version implikuje getRpmVersion() Plik "/usr/share/rhn/up2date_client/rpmUtils.py", 257, wiersz powrotu getRpmVersion  Up2dateErrors .Produce up2dateErrors.Rpmerror("Nie można określić, którą odmianę RPM posiadaszuruchomiony.nJeśli zostanie wyświetlony ten błąd, eksperyment ma nnttrpm --rebuilddbnn")up2date_client.up2dateErrors.RpmError: błąd RPM. To było:Nie można określić stylu wiadomości RPM, z którego korzystasz.Jeśli użytkownicy napotykają ten błąd, spróbuj go uruchomić              bunty na minutę --rebuilddbOczekiwane wyniki: Up2date powinno zostać uruchomione, aby otrzymywać aktualizacje aplikacji.Dalsza informacja:Skopiuj RPM 4.1

    komentarz 1 Adrian Likins 2002-12-02 22:09:38 UTC

    błąd obrotów up2date na minutę

    Jedną z pierwszych rzeczy, które wyróżniają up2date jest próba, która może rozgryźćjaka wersja mojej funkcji i produktu. Tenprosząc o dane dotyczące opublikowanej wersjiPakuje twój dostarczony pakiet "redhat-release" i często najważniejszy pakiet "rpm".Wygląda na to, że nie istnieją w Twojej bazie danych (onijest to wymagane do aktualizacji, więc najwyraźniej zawsze powinno być instalowane...)